2nd Air glass not responsive on any devices after 120Hz Beta update


Please help, here are the sequence:

  1. Got the glasses yesterday (my 2nd one) and used it on Galaxy Fold 3 (One UI 5.1 Android 13) and it works very well

  2. At night, wanted to go for 120Hz so updated it and update was successful but the glasses responded so much slower and screen started going on/off at random intervals


  1. Removed the app and then retry, same problem

Currently I have 3 phones and 2 Nreal glasses to which I will call

1st one : Nreal (the 1st one) and

2nd one : Air (the 2nd one since u guys rebranded) and the 2 phones are

  1. Samsung Galaxy Fold 4

  2. Samsung Galaxy Fold 3

  3. Samsung Note 20

All of them are on Android 13 and One UI 5.1

Nreal + Galaxy Fold 4 works 100% no problem at all in the below set up

Since Fold 4 have the newest Nebula (the Beta one for 120Hz), it turns on and I can click Air Cast but then the picture kept turning on and off like its connected/disconnected (this is what I can see from the Nebula app)

Note 20 (no Nebula and no auto Dex) + Air

It takes a very long time for the picture to come up but is also turning on and off at intervals

Fold 3 (removed Nebula and turned off auto Dex) + Air

It shows the following on/off USB connection

So I figured it might be a firmware problem so I figure might be worth downgrading the Air from the 120Hz Beta version so I connected it to my Macbook to which when I switched on the Nebula App, it discovered the glass and started updating the firmware which is a good sign. While updating at 24%, the screen switched on and I was elated - Yay…then it switched off again and once finished updating, the screen continued to stay off…sigh…

So then I connected it back to my Fold 4 (Nebula 120Hz hoping that the Fold 4 but not turn connect to Nebula app so that it does not update the firmware back up again) but the result is just as bad, no picture…

So then I turn on the Nebula app (Fold 4 + Air) and then it started updating…but the result is that the phone stopped detecting it all together…

Along the way on the Fold 3 since its the worst impact since it appears the Fold 3 is most screwed, I also tried to clear data on the USB C and USB on the Fold 3 to no avail, the phone seems not detecting any glasses at all even with Nreal (but not with Nebula app turned on since I don’t want the Nebula app to screw up the Nreal glass on top of the already screwed Air). Will probably end up factory resetting the Fold 3 just to figure cuz we tried every possible combination.

Note 20 with Nreal - works perfect

Macbook with Nreal - haven’t tried cuz it would then downgrade the firmware on the Nreal back down from the 120Hz version

The last thing I wanted to try was to go to the website and do the proper firmware update to the glass so I went here: XREAL Air - Firmware update and
here is the result… all successful…the glasses showed the screen during 10% or something of the firmware update, yay!! but then turned off and never turned on the screen again…

So after the update:

Note 20 (no Nebula) + Air : Connected, no display

Fold 3 (no Nebula) + Air : Nothing…no detection, no display

Macbook (Nebula) + Air : Didn’t try cuz then it would change the firmware again

Fold 4 (Nebula 120Hz) + Air : Didn’t try cuz then it would change the firmware again

I think I must have lost 20 hours of sleep trying to get the glass working…Any ideas?

Hi, seems like the DP firmware is failed to be updated. Please use the following link to downgrade the firmware, and note that the DP part is required to be updated.

Please see the above picture, I did all that and it said it was 100% complete. I should do it again?

Yes, please do it again by the link I put above.

Ok, will try and revert!