Beam not working

Ok so got my beam today excited…went to plug my light in…nothing…blank screen. beam light up I made sure it was charged glasses blank screen I held power and orange button to see if somthing would happen…my glassds ight up asked me to connect to.wifi…downloaded the 700mb the beam looked like it was installing…it reseted came back on but screen is blank again…tried several holding buttons turning beam on and off plugging it in phone…nothing…black screen…help?

update…so when I plug my light glasses into my phone I get an 3d error when trying to use the nebula ar vrs screen mirror…so Im guessing my glasses firmware could be messed up and the beam cant read whats comimg from my glassses??? and if so how can I reistall the firm wear to glasses for light cause in the app it says you can only reinstall for air glasses.

Hi, I doubt that there is something wrong with the firmware of your Light, please confirm what phone you used to test the Light in AR Space.

So I have multiple phones my s10 e and s10 5g work with dex in my light but not the ar zone only(which is why i was buying the beam) screen mirror. My s10 plus did work in ar zone before I used it with the beam when i was trying to set the beam up but now when i just plug my lights into the phone only i get mirror to work no dex and when i try to switch to ar zone i get 3d error and says to try to plug the glasses in again. s10e and 5g are only still on andriod 10 for gear vr reasons so i know im not going to ar zone witch is fine but my s10 plus in on android 12 and ar zone was working before i hooked it up to the beam. I worked to start the update to the beam but now theres just a blank screen…I dont think the beam even recognize the light because when i plug it into the beam it dosnt auto turn on. I have to manually turn it on. Also isnt the beam suppose to be used as an alternative to none supported devices? …I also have a s20 fe at work ill try to bring it home and see if the light works with it…it did before.

Seems there are two issues, the first is that the AR Space cannot be used with Light on your S10. The second is the Beam shows a blank screen when connecting with Light.
About the first issue, please check if the mode of the Nebula is switched to 72Hz; For the second, the Beam just works as a device that provides 3Dof virtual screen for multiple platforms. Do you have any other glass for further test on the Beam?

ok so no dont have. other glasses today i tried again got the glasses to work again with beam again to set up and connect to wiffi…saw option for mirror android mirror apple ect. But I unplugged it from the glasses and now im back to not getting the beam to show up in the glasses again…if i plug them in one way the beam wont turn on if i flip the plug around and plug it in the beam turns on but no picture… then after waiting a bit the beam turns itself off. Im making a ticket to see if i can get a return or exchange

Also sometime i get sound from my speakers in my light but no screen then beam times out and shuts off. I can turn it back on from the power button get sound again but no screen

update…so after using my s20 fe 5g i was getting that 3d xreal error and figured out if you go into samsung settings and switch it from dex to mirror and go to nebula app and reset data and cashe the ar would work again in my light…it also worked to fix that error on my s10+…thr Beam how ever is still not sending video output ti glasses…like i said sometimes i can here sound through the speakers but no video. I tried hooking the bream up to all my phone and comp and it only seem to want to charge the beam…us there a way to reinstall that 700mb update befrore I return the beam??? im really trying on my end to fix it.

There are two ways to reset the Beam but it cannot reinstall the update package. The first is to hold the Turn on/off button for 15s, and then press it for another 3s. The second is to enter the the Setting of the Beam and reset it.

Ok update…So I bought a pair of Xreal Airs from a local pawn shop and the beam works perfect with Airs. So the issue is with the xreal lights…not sure if anyone else has this problem witch is why theres seems to compatibility issue with the beam and light, or the lights need to be updated firmware wise…still wont send video signal to glasses…its weird because I got it to work twice randomly pluggin it in and out 100 times. Lights work perfectly fine with phone and windows computer. Just trying to help. I’ll keep both for now…I actually like the lights a little better both have their pluses…feel the fov is just right on the lights compaired to the airs…the airs colors tho are nicer then the lights, and the speakers are also better in the Airs. Would be a bummer if your support for the lights isnt the same as the Airs.


ok found a weird fix dont know why. I have bought in the past type c male to type c female adapters…like 5 bucks a pice. Odly if i plug the adapter into the beam and into the light glasses the beam turns on and shows the screen every time…grant it you can only use the features of the beam for the airs…unless the devs change it…but its still nice for extra battery. Hope this helps.

Hi, I have a Light and a Beam as well and, based on your comment, tried a F-M adapter between the Light and the Beam but had no luck. Is this still working for you? Could you provide a link or info about the specific adapter you are using? Thanks.

Not sure if this screen shot worked but its from ebay from a few years ago and its not for sale anymore…the best I can do. You also only really only get the benefit of the extra battery and streaming. It wont let you ajust the screen like it does with the airs…I have both and it seems they dont seem to care about the lights as much as the airs.

I can see it, thanks! Yeah, being a Light owner has been rough but I will still keep them and probably buy a Light 2 when/if that happens. May have to just stick with Nebula for Windows with them. I have a Surface Go 2 that slips into a hiking sling back and works great with them.

1 Like

Hello . I had my beam plugged into glasses and socket at same time .it went really hot and suddenly went off and now it’s not working??I plugg it in electricity and I feel it get warm so it must be alive still ?how can I reboot it or fix it ? because now it’s not working at all no light nothing and where is start button ?is it the one on front small button ?

Hi how can I reboot it totally ?it’s not working no light showing .it died on my when got over heated . It’s like it’s still alive because it’s warm when plugged in socket ?but no light and not connecting to glasses

Hi, please hold the Switch on/off button for 13s, after that hold it for another 3s to turn it on.