Cannot build project on Unity for nreal with Ubuntu 22.04


Because of reasons I had to switch to a Ubuntu distribution. On my Windows machine and NRSDK version 1.8 everything worked fine. The projects could be build with no problems, could be installed and could be started. The only problems I encountered there were my own mistakes and easy to fix.

Now I had to install Unity on PopOS an Ubuntu 22.04 distribution. I installed any necessary .Net stuff and fixed an issue with OpenSSL where I had to downgrade to 1.1 for Unity to run.

The projects run in Unity like a charm. I can debug code with no problems and everything seems to work fine. Building it gives me always different errors.

Failed with at least 2 errors while 4 being the max. Never showing the errors themselves except for 2 of them. They never are shown simultaneously. But mostly it just says there are errors and not showing any.

One being that some thread niceness is 5 instead of -5 as it should be.

The other being something with gradle where I just used custom gradle packages and the error was gone but the others persisted.

But after a restart the build errors are gone like I mentioned in another Topic.
I can build but when I install the apk and open it, it just shows nothing for like 10-30 secs and then close the app to show the home screen of the nreal.

I am using adb connection over tcpip which works really well. adb logcat had even with the ‘-s Unity’ way too many logs to read from the beginning to the end. When I filter for my package name I just get this:

--------- beginning of main
--------- beginning of system
07-08 12:51:28.295  3594  3612 I com.Iniationware.NrealTestStuff: android::hardware::configstore::V1_0::ISurfaceFlingerConfigs::hasWideColorDisplay retrieved: 0
--------- beginning of crash

And after starting the app in question:

07-08 13:02:35.316  4246  4264 I com.Iniationware.NrealTestStuff: android::hardware::configstore::V1_0::ISurfaceFlingerConfigs::hasWideColorDisplay retrieved: 0

This line repeats itself after some time or every try to start the app.

I really should have saved the logs from the errors before but I didnt think they would just disappear randomly like that.

I hope you could understand my problem and can help me a bit.

Best regards,


Hi developer. So what version is your Unity installed on Ubuntu? And are you using a dev-kit or mobile phone for the test? A full log file is much better for analysis. Could you please send me the log?


I am using the dev kit and the Unity version 2021.3.5f1.

In this pastebin is the logcat with the -s parameter of ‘Unity’ accessed with wireless adb. I tried to save the logs without any filter but the output was just too much and the terminal started deleting lines at the top.

I started the logcat 5 seconds before starting any built project from Unity and ended it around 5 seconds after the project has ‘crashed’ or rather returned back to the homescreen after doing nothing.

Are there any other logs you might need and where do I find them?

Thank you for the help!

Hi, developer. Thanks for your log, we have checked your log file and found that it was caused by incompatibility. I also confirmed with R&D and was told the Linux system is not compatible with NRSDK. Please notice that.