Can't update the glass firmware

Hi, I have a problem to connect my Nreal light Glass to Phone Xperia 5 ii/nebula v3.1.1.

When I insert the glass to the phone, it will start the firm updates, after it done, it will just say “Failed to synchronize with your glasses, please unplug and plug the glasses back in to try again”…
I did the activation on the web site, but still doesn’t work…

one more thing, after I connected the phone without any success. I connect my compute unit. now, it just keep to says “Permission is not granted properly, please reinsert…” …
tried reset everything… still the same thing.

Is anyway to fix those error?


Hi, seems like the update of your glass failed. Could you please tell me if your Light is red?

Hi, Thank you for replying .
Yes, the glass is red with logo on the side, and no buttons.

The red one seems to have the issue. As you know, the red one is our first-gen product, the old firmware has some compatible issues with the newest Nebula.

so, this means it won’t work at all?

Honestly, yes. Really sorry about it.