DevKit Controller no longer connecting

I have just received the nreal devkit, was using it with no problems, did a software update to latest, all was good still

after about 10 minutes on the latest update the controller no longer syncs or ligths up

I used Scrcpy and in the bluetooth settings the controller is in the list but not connected
if I try to add it as a new device I get an error saying it couldn’t pair, (the controller also has a strange name of DfuTarg) and gives 'incorrect PIN or passkey. as the failure

any help would be appreciated :slight_smile:

Hi, Mike. You mentioned that the controller never lit up, and got connection failed. But could you please leave the controller to be charged for a while, then check if the light can be on?

I did try letting it charge, both turned on and off…

like I mentioned earlier, I see a device show up in the bluetooth list, it just fails pair with incorrect pin or password as the failure (also long pressing the ok button never makes it flash either)

and the issue only start not long after the auto-update finished, is there a way to manually check that the software on the controller is not corrupted somehow?

OK, thanks for this info. Could you please send me several screenshots which can show the Bluetooth list and error tip in Scrcpy?

there are no errors thrown except the popup in this screenshot

(sorry, clicked too fast and double posted)

The listed devices are not controller. Please check if your controller are charged correctly and turned on. The three pins should be matched with computing unit.

That\s why I said something went wrong, when the controller is turned on, that is the name that shows up in the bluetooth list

right, so not having the controller means I cannot click “english” as the language… so I can’t initialize and use the devkit at all currently due to this controller issue

OK, thanks for the further details. And sorry for answering lately. Then please contact after_sales team for further help. The email address is

still no response from them,

I also tried using an xbox controller to see if it at least recognized a different device… but it looks like the nreal app only registers a single button ‘B’ which cancels and doesn’t confirm,

so my device is essentially bricked at the ‘welcome select language’ screen :frowning:

I have notified the after-sales team, and they will deal with your issue with high priority.

1 Like

Received the new controller today,

let it charge a bit, turned it on and synced no problem :slight_smile:

everything seems to be all good again!

it’s too bad there is not way for the devkit to force update controllers bios :frowning:

Hi, glad to hear that you received the new controller and solved the current issue. And thanks for your suggestion about updating the controller. We will consider this similar way in the future.

I have just had the same issue. Is there a solution?

Please follow the troubleshooting steps above, if doesn’t work, then you can drop an email to for further help.

Ive written to this address twice now and keep getting a rejection. is there a better email to send to?

Delivery has failed to these recipients or groups:
The server has tried to deliver this message, without success, and has stopped trying. Please try sending this message again. If the problem continues, contact your helpdesk.

The following organization rejected your message:

OK, then I will drop you an email and involve the after-sales team, please tell me your email address.

@XREAL-dev Still havent heard back. ANy help would be greatly appreciated.

Please tell me your email address, then I can ask our after-sales team and track your email.