Error code-5, Please Connect your Nreal Glasses

Hi, I’m developing app using RGB Camera for Computer Vision.
Before testing my project application, I tried to run ‘RGB Camera-Record’ demo build app for testing a compatibility of RGB Camera on my smartphone.

When I run the demo app, it just prints “Error code-5, Please Connect your Nreal Glasses.” on the smartphone screen and nothing is printed on the nreal…

I purchased LG U+ Samsung S22 Ultra [S-908N model] and connected it to Nreal with U+ 5G model.

I followed all instruction on NRSDK gitbook and built a real simple app.
Why does it happen and how can I solve this issue? PLEASE HELP
I tried the app through both ‘Nebula with LG U+’ on One Store and ‘Nebula’ on Play Store.

  • I still get same error message without connecting nreal glass.
  • I tried a nebula recommended app ‘ARON AR’ and it works fine.

Hi developer. Could you please confirm if you opened your sample app through Nebula MR Space? Please go to MR Space first, then open your own app. This error tip often occurs when app is opened without going into MR Space. Hope this info can be helpful to you.

I opened ar apps through MR Space mode.
This is the record screen through nreal glasses
I’m really interested in the nreal glasses and want to make my own apps on this platform :smiling_face_with_tear:

which version of Nebula is compatible on my case?
LG U+ Nebula or Nebula on Play Store.

Please use Nebula in Play Store.

I downloaded other recommended apps on nebula(Play Store) and tested them.
‘Return to base’ works which seems to use plane detection
‘Table Trenches’ doesn’t work. 'Not working 'toast pops when I open the app
‘ghost hunter’ works pretty.
Are these app made on unity environment? I should find commons of the apps working fine

Yes, we only released the Unity version of NRSDK, so these apps are made in Unity.

I figured out the error.
The problem is on a build setting.
For Galaxy S22 Ultra(In South Korea region), its processor type is armv8a which is arm64 and graphic is OpenGL ES 3.2.
So, on ‘Other Settings’ in ‘Player settings’, Require ES 3.2 should be checked and Scripting Backend should be IL2CPP and checked on ARM64.
The first one isn’t noticed on gitbook, so people ,who suffer by similar issue, double check this part

1 Like

Actually Not figured, It doesn’t work now. I don’t really get it why it worked before and now it doesn’t…
I can’t focus on developing app before escaping from the building issue.
Please… check if there is wrong setting on Build Setting.

Could you please change the Scripting Backend back to Mono and disable ‘Developement Build’?

Sadly, it doesn’t work.
Is it okay to build with Scripting Backend Mono on ARM64 cpu structure?

Nope, if Mono, then Armv7; if IL2CPP, then Arm64.

So, in my case with Galaxy S22 Ultra with Snapdragon , it should be fine with IL2CPP…?

Can you tell me which Unity LTS version you are using for developing NRSDK ?

I tried V2020.3.33f1c2 and V2021.3.4f1c1, both worked. Please follow this flow, install your app–>insert glass–>then enter Nebula MR Space–>open your installed app.

I followed the flow but no difference :smiling_face_with_tear:

Very strange, maybe we can arrange a Teamviewer meeting? Then I can check your steps and find the problem maybe?
Or you can record your screen and I will check your steps by video?

I’m reinstalling the unity platform… Can I try it after this?

Yes, please try to record your screen after re-installing. Thanks in advance.

It was Unity issue.
All packages from 1.8.0 to 1.9.3 experiment work smoothly.
I think, because I am handling a lot of experimental packages like Barracuda, the Unity crashed and affects to building an application.
Thank you for your help and Sorry for bothering you about the issue on Unity Platform.

Glad to hear that the issue was solved. If you have any issue or question during future development, please feel free to let me know.

1 Like