Hand Tracking 'Grab' failed in Nreal SDK v1.10.0

I tried Nreal SDK v1.10.0, but the ‘Grab’ Posture failed in demo scene…
Can anybody check it~

I import the SDK as before, and the hand tracking demo just didn’t work

Ji, I will test it and give you feedback.

hello~ Any progress yet?

Hi, the ‘Grab’ gesture is working from my side. Please check the following pic.

Can you click ‘SwitchHandVisual’ by pressing Left Shift and Left Mouse Button? I can Grab but cannot ‘Select’~

Thanks for this info, I also got the issue, and have given feedback to R&D.

1 Like

I want to know when this problem will be fixed~ Maybe in this month?

Hi, we’ve solved this problem, just add a line of code as shown in the screenshot.

        public bool isPinching
            get =>
                Input.GetKey(KeyCode.Mouse0) ||
                currentGesture == HandGesture.Pinch;

1 Like

I tried it, but the issue still appears~

Maybe it’s not very sensitive, try it a few times and see what happens.
屏幕录制2023-01-10 10.12.55

ok~,btw will the hand visual in this gif be available in the next version of NRSDK?

Yep, it’s our new hand visual:)

Look better than previous, but it seems like a solid gray rather than a transparent material with adjustable rim light~