Help! NRInput suddenly disappeared and a grey dot at the bottom of my UI/Canvas instead


I’ve had various screens of my own working for some time, and I began to add other screens. Suddenly, and I do not see what has changed, the NRInput has stopped working and shows a small grey dot at the bottom of the screen / canvas.

There is no laser pointer showing anymore…

How do I reset or get the NRInput back? I just saw that 1.10.0 is out so I upgraded but it is still the same…



1 Like

Well “reset” simply means deleting the NRInput, then dragging a new NRInput prefab to the scene. Of course, this is only works out of the box if you’re original NRInput is unmodified. Any additions to it will be lost and you’ll have to setup it up again.

What do you mean adding more screens??

Hi Tilley,
I notice that this dot is close to the bottom of the screen, maybe you can pull it up a little bit and see if there’s any laser as the gif shows. By the way, you can press SHIFT and move the mouse to control the laser.



Ah I see what you mean; this ‘weird dot’ is just a static end of the pointer. I’ll try later after work :).


Ah yes I tried the usual delete, add new etc…comparing it to the NRInput in the demo scenes. I’ll bet it is something subtle I’ve changed when tired and couldn’t see it (also tired last night after day job!).

I’ll try later after work.

More screens → I have a scene per screen of my app and I’m chaining them together. In the last few days I’d been working on elaborate splash and launch screens; I went back to my main (widget heavy) screen and ithe pointer had stopped working.

I shall check again later! :slight_smile:

1 Like


Thanks for the tip regarding Shift; I knew that spacebar moves the pointer in one plane but then after you told me I checked and Shift did make it move. Are clicks on widgets meant to work in the Unity emulator? Or just moving laser pointer around? As it is useful to test in the emulator before devbox or phone (although both are fairly quick as for phone testing I just send the apk up via GoogleDrive and down to phone).

Interestingly, on my main widget heavy screen, running inside Unity, spacebar and Shift do work and make the pointer appear, but on another scene/screen only Shift works.

I did try on the dev box and the pointer wasn’t appearing but after work/this weekend i will rebuild and check on devbox and phone.



Hi Leigh,
I hope the following info will be helpful to your development process.

  1. Clicking on the virtual controller(touchpad) is meant to work in the Unity emulator. You can use this way for a simple test.

  2. Actually, we often use the command adb install xxx.apk to conduct tests, which is faster than the way you do now. Before doing this, you need to connect your phone to the computer in a wireless way. Here is the instruction:

  1. Check the WiFi IP address of your mobile phone ;
  2. Connect the phone to your PC via USB
  3. Open cmd, enter the command: adb tcpip 5555
  4. Type command: adb connect IP address. This IP address is the WiFi IP of your phone;
  5. Disconnect your mobile phone;
  6. Open cmd, enter the command: adb install [PackageName].apk

In this way, you can easily install your apk on your phone without taking off your glasses or moving your phone. In my personal experience, after the first set up following the complete process, the subsequent connection actually only requires steps 1 and 4 for wireless debugging.


Ah nice one; thanks for the tip I shall try that out! :slight_smile:

So I rebuilt everything, deployed and now it works…I can only guess that perhaps I was tired or did something weird…who knows! haha. I do notice every now and again I have to restart apps as they freeze or crash.

I’ll add some debug if I see weird behaviour again.