I cannot update Nreal System of a dev kit

I have dev kits. Some dev kits receive the system update via wifi, so glasses show the update instruction automatically and I can update the system. But, some dev kits do not receive the auto update. Even if I check the setting, glasses shows “Your software is up to date”, so I cannot update.

This is the versions of the dev kits which do not receive the update automatically:

Nreal System Version: SDM845-202103181936-716
Nreal Light Controller Version: Jul 21 2021 03:23:18 release
Glasses Firmware Version:

I am waiting for your help. Thank you.

1 Like

I found a solution. If you are interested in, please contact me. I would be able to tell how-to and help you. in short, 1) open scrcpy, 2a) manually tap and open Update app or 2b) install and tap ota.apk.

Hello, I am encouraging the same problem, how to update it?


Did you try this?

Yep,but it doesn’t work

I solved the issue with that. Fmm, no instruction for system update is not displayed on your dev kit, right?

Yes,to make matters worse, I tried to restore the factory settings, but now I can’t get into the MR space after connecting the glasses

It hears more complictated issue… I guess there is no topics to be able to discuss here. Sorry.