Image Tracking Not Working AGAIN -.-

I’m using Nreal SDK 1.9.5.
I build the demo scene ImageTracking and the image tracking funtion just work for the first time, and never worked again.

I follow the step by step instructions on youtube (Nreal tutorial), and it doesn’t work at all. And I just don’t know which step went wrong, there is no feedback in Dev environment.

Wondering if anyone can point me to the right direction?

Many Thanks:)

My steps are as follow:

  1. open a new unity project and import NrealSDK(1.9.5), all issues are fixed
  2. ENABLED ‘ImageTrackingMode’ in NRKernalSessionConfig & DESELECT ‘Nreal Air’ in NRProjectConfig
  3. directly build DEMOS/ImageTracking, 0 change 0error
  4. apk build successfully and installed via adb
  5. open the target image on my monitor(27 inch), and the second picture is the real working environment
  6. open app in Nreal Light

– Until Now Everything Works OK-- the Nreal APP can Track The Image, Next, I try to custom the target image.

  1. Select the target image and resize with Adobe Illustration (ppi set to 150)
  2. drag into Assets\NRSDK\Demos\TrackingImage\Images
  3. regenerate the TrackingImageDatabase
  4. fix missing issue in NRKernalSessionConfig
  5. rebuild apk
  6. install it and try to track the image

–The entire tracking service failed to track images including images tested before-- Wondering if anyone can point me to the right direction?

1 Like


Hi, could you please send me the image, I want to test it from here.

I tried a new image, another thing is that I just simply regenerate the TrackingImageDatabase and build the demo, the entire function just fail to run. That’s wired.

Let me try this image first, and give you feedback.

Hi, I tested the image you sent, and it worked from here. There are several points I need to mention:

  1. After you create new imagedata base, please make sure the NRkernal Session is also changed and the new Tracking Image Database should be selected:
  2. Once you added the image to the Image folder, please change the ‘Wrap Mode’ and ‘Max size’ like the following shows:

I did and it’s still not working -.-

the current situation is:

  1. Directly build the demo = WORKS
  2. I delete the TrackingImageDtabase and Simply Regenerate it
  3. Drag new database into NRKernalSessionConfig
  4. build the demo again = FAILED

It just failed to work after Regenerate, without adding new iamges, I’m wondering what’s wrong in this step, can you send me the apk or share the project?

I also got the same issue when I tested, but I found the cause. It was because the ‘Max Size’ in your picture is too large, which reached the maximum performance of the Image Tracking function. After I changed the setting, it worked. I attached the apk I built, please try it to check if it is also OK for you.

Good news is that yhe apk you send me works well,
So, you steps are:

  1. drag the target image
  2. change Wrap Mode and Max Size
  3. regenerate the TrackingImageDatabase
  4. drag new database into NRKernalConfig
  5. rebuild the apk

is that all?

Yes, please follow these steps.

I did all the steps and again, it failed QAQ
I record my process here: Desktop 2022.11.25 - - Google Drive

Seems I found the difference. Please check what I did from the following video:

Oh I see the difference, I will try it later. Hoping it works, haha.

Finally it works, yeah~
And I still wondering the difference between NRSDK/NRKernalSessionConfig and NRSDK/Demos/Config/SessionConfig_Demo
While doing my own project, which ‘Config’ should I care about?

Just to hook in on this thread.

I still have issues with Image Tracking as well. Recognition is fine now, but the Width in the Image Database is always reset to 0.397(m), so I cannot use smaller trackables at the moment. Which is quite annoying.

When doing you own project, please focus on the NRKernalSessionCofig file, and call this file in your project.