Laboratory Features - Third Person View

I am trying to use the Third Person View feature in Laboratory Features in Nebula. Here are the steps I followed:

  1. Install Nebula and the Third-Person Camera app on Android phone #1
  2. Install Nebula on Android phone #2
  3. Open Nebula, login and click the Mine icon at the bottom right on phone #1.
  4. Click Laboratory Features
  5. Click Capture Others
  6. Enter my login ids and click Ask To Record. The 60 second countdown starts.
  7. Plug the nReal Light glasses into phone #2
  8. Once Nebula opens, login and click Mine icon at the bottom right.
  9. Click Laboratory Features
  10. Click Captured by Others
  11. Go back twice and click Glasses and AR Space
  12. AR Space opens and I see the prompt that phone #1 is asking for permission to connect. Accept the connection.

I then see a green light and it says Connecting but nothing happens on phone #1, the countdown goes to 0 and it asks to ask for permissions again.

Both phone #1 and phone #2 are on the same wi-fi.

1 Like

Hi, could you please confirm the version of Nebula for me? Also, please simplify the steps, just keep the glass connected with phone2 and enter AR space, then click capture request on phone1 and enter the login details.

It’s version 3.2.1(2551). I’ll try your recommendation and report back.

1 Like

When I enter AR space with phone2 and then click capture request on phone1 and enter the login details I don’t see the option to accept the request anymore. I can only get the option to accept the request if I click capture request on phone1 and enter the login details and then enter AR space with phone2.

I tested the function from my side, it worked well. When I requested the capture, the phone would ask you the recording permission, could you please check if you have authorized the permissions for both phones. By the way, please tell me your phone models, and you can try to use 4G network for test.

I’m happy to hear it worked well for you, it is still not working for me or my customers though. When you say have i authorized permissions for both phones what does that mean? When i do get the prompt in phone2 that phone1 is requesting permission I click accept. I then get a green light and the word ‘connecting’ but nothing happens.

I’m using a Samsung S21 for phone1 and an LG V60 Thinq for phone2. What do you mean by testing with 4G network?

Hi, the mentioned ‘authorized permissions’ is recording permission of your phone, when it is connecting, your phone will prompt a notice to tell you to allow recording for this function, so I wondered if you got this notice when you use this function. If not, then I think the connection of the two phones are not built well due to the network condition, so I suggest you switch the network to 4G or 5G (Cellular Data).

Yes, i get notification in AR space that phone1 is trying to connect to phone2 and i click on accept i see a green light and the word ‘connecting’ but nothing happens after that.

I thought both phones need to be connected to the same wifi, is that not the case? Why is 4G being recommended, can the apps talk over cellular data?

What I meant is that you can use another phone which uses 4G and turn the hotspot on. The tested two phones are connected to the hotspot.

Are there any logs that can be reviewed to see what is going on?

Please use the logcat tool to catch log, there is a guide for you. The Steps of creating log.pdf - Google Drive