Laser Pointer in scene but not clicking / no circle at its tip


What would generally stop a button receiving clicks?

I notice that the laser pointer shows a circle at its tip when it is active/things are clickable.

I just built a new screen/scene and it is a title screen so the main animated logo, and title above it, are set back (1.5) and then I have a start button on its own panel in the foreground (at 1.2). NRInput is loaded as I can see the pointer and move it around however there is no circle at its tip and my button cannot be clicked. So it is as if it thinks there is no widget that is clickable.

I’ve been comparing it to another scene of mine where everything works as expected but I cannot see any differences.

Simple setup:


I didn’t receive any replies so what I’ve done is to make a new scene and build it up slowly bit by bit.

I think with the one that is not working quite right there must be something I cannot see stopping the pointer. As in a new scene I have two canvases, one in foreground, one in background, and the button in smaller foreground canvas is clickable.

So I’ll build on this new test one to transform it into the one above and see if anything breaks behaviour along the way.

1 Like

I built just the front button holding canvas in a new scene. It all worked as expected and I copy/pasted it into the scene I am building, disabled the broken one, and it all worked! :slight_smile:

So no idea why but a good reminder to sometimes ditch ‘must fix this’ in favour of constructing a component outside to then drop in and integrate! :smiley:

1 Like