MR space shakes when phone is picked up

Hi there!

When I connect my Nreal light glasses to my phone (Oppo find x3 pro) and start up nebula, Aircasting works but as soon as I try and use MR space de screen completely freezes and begins to shake. (like there is some kind of problem with the calibration)
The weird thing is that when I start up MR space and don’t touch the phone it just works like it would normally do, but when I touch/pickup the phone slightly it starts to shake.

I think it relates to a problem with the gyroscope in the phone but the compass app is still working fine. also MR space just worked 2 days ago like normal. I’ve already tried installing different kind of nebula versions but none of them worked. Even reinstalling the phone back to factory settings didn’t help.

Hopefully there’s someone that has experienced this problem before who can help me or lead me in the right direction. If you have any idea please let me know.


i got the same problem before and I solve it by install another version of Nebula that match my android version.
I hope it would help

Hey @aurelia,

First of all thank you for your response. Unfortunately we have installed several different versions and none of them seem to work. We have tried both 1.07.00 and with three different service apk’s (1.04.08 ; 1.08.02 ; 1.09.04). We also checked the obb file but everything seems to be correct. Also when we install 1.07.00 nebula tells us that the phone is not supported and when we continue further down de menu it eventually ask us to download the service apk but it is already installed. Where exactly did you check what the right nebula version was for your device? We downloaded our software from apk combo but have you downloaded it from some where else?


Hi @Tiyani ! sorry for the late reply!
I am using the nebula version of, and my android version is 11

Hi @aurelia,

Where exactly have you downloaded that version from. We could only find

Thanks for your reply :slight_smile:

To all the developers reading this,

We finally found out what the problem was! If anyone ever has a problem where the MR space just crashes on startup and begins to heavily shake, make sure that the truetone/naturetone functionality on your phone is turned off. With our device it was turned on by default and it prevented MR space to work. Maybe @XREAL-dev could fix this in a later update but for now we’ll just leave it turned off.

Hopefully it’s helpful to someone that has the same problem.