My dev kit's power has stopped working

Hi everyone,
I has been using an Nreal Dev Kit for about one month. Today, its power has stopped working. In other words, even if I push/long-push the power button, the LED does not work. Is it broken? Does anyone have the same experience?

I had the same issue. The computing unit randomly switched off and wouldn’t switch back on. I thought it had run out of power, but after a night of charging it still wouldn’t power on, no lights working or flashing at all. I left it a week thinking it was broken, then tried to plug it into my PC again and it came back to life, lights turned on and flashed for charging.

All I can think of is that the computing unit had some kind of crash and needed the battery to run out in order for it to be able to reset/reboot, and since I charged over night it took forever for it to run down.

Get in touch with support, but hopefully it will come back on in time. This is where a removable battery would come in handy.

Maybe your controller is run out of power, please use the charger and then see whether the LED light work.

In this case, please press and hold the “power” button for more than 20 seconds and then see if the light works.

Thank you f0ld. I will try that you did.

1 Like

My controller is fine and its LED works. I meant the “computing unit” does not work. The LED is always off even if I push/long-push the power button and connect the unit to a charger.

Thanks for the reply, but nothing worked in my case until the unit ran out of charge. The unit was completely dead, wouldn’t respond to anything, not even a long press. Then when it finally ran out of charge and I plugged it in, the lights miraculously came back on.

As odd as it sounds, it’s quite reassuring that someone else is having the same issue and it wasn’t just my device.

Sorry for the inconvenient and we need to confirm two questions. 1.Did you long-press the button for more than 20 second? 2. Is your computing unit still cannot power on? Please use the typec cable to connect to the PC’s usb port for about 1 hour first, if the LED still does not work, then long-push power button again for more than 20 seconds. If the above steps still cannot solve the problems, please contact .

Does this case still recur?

I tried to turn the power on by long-pressing as you mentioned, and the computing unit worked today! The LED also got its green light. Thank you so much for your advice!

I pressed the power button for ~13 sec and then the unit was turned on. If you have similar problem, please try to leave the unit >1 day without charging and press the button for 20 sec.


Other work has sadly taken priority since it happened, as the unit was ‘broken’ for a week and other things took priority. I don’t know if it was just one off as I haven’t really used it since.