Nebula App MR Space - 2D apps -unrestricted apk

Hi @XREAL-dev. Is the Nebula app available for download with 2D apps in MR space enabled (I mean with no device check)?

I have a OP9PRO with bootloader unlocked and rooted. I want to see if I can get it working fine on that.
Just to be clear: I wouldn’t expect any help with it. I only want to try and get some 2D apps in MR space to use this device and the glasses as a daily driver for work.

The google play one seems to download a different apk depending on region and device.
Take care!

It’s my understanding that Nebula has two parts, the actual Nebula app, and the Nebula Service.

I believe that the Nebula Service is the part that gives access to Nebula to view and run 2D apps.

I don’t really know where the Nebula Services can be downloaded. I checked some apk websites like APKPure and they seem to have it. But from past experience I think you’re supposed to use the Nebula Service with the same version as the Nebula app.

1 Like

What seems to be the case. I did find a few versions of Nebula APK and OBB files and trying to find someone willing to dump a full ROM from an brand new/factory reset OPPO Find X3 Pro with that option available. I’ll try to extract stuff from there.

Either I want to start working on my unity skills to get browser, VNC and a few other things working. My main goal would be to use it as daily driver for work after Christmas.
As for a realistic target for myself:

  • 4-5 browser windows able to access guacamole and PiKVM/TinyPilot
  • VNC client
  • Being able to have spotify in the background or even youtube playlist running.

Everything else on top of that is a bonus :slight_smile:

P.S. I did find nebula service on g play store. I’ll try to install that as a system app next week with root permissions and see how it goes (via adb of course)


Wow, I wish you the best of luck :+1::crossed_fingers:

1 Like

The nebula service was shared in the slack channel a while back, however it failed to install on my OnePlus 8 and 8T. I believe it was only available under very specific circumstances, and for certain phones.


Not sure if this works, but this is the link to the Slack Thread

1 Like

Carlos May 27th at 5:35 AM
Can you share the nebula service ? You should be able to find in the apps section and show all process
11 replies

Starshell  4 months ago
I extract this with an APK extractor. Not sure if this works.
Nebula Service 1.08.02.apk
17 kB APK17 kB — Click to download

vlastimirs  4 months ago
Try installing it through ADB and then pick up the error messages (if any)

Carlos  4 months ago
Yes!!!! It works after installation of the nebula service

J.H. Zwart  4 months ago
This APK fails to install on my Oppo Reno 10x Zoom (Android 10). ADB displays this error:
adb: failed to install Nebula Service 1.08.02.apk: Failure [INSTALL_FAILED_SHARED_USER_INCOMPATIBLE: Reconciliation failed...: Reconcile failed: Package ai.nreal.nebula.service.oppo has no signatures that match those in shared user android.uid.system; ignoring!]
Is there anyway to bypass the signature check? Or to see which phone models are supported (X3, X3 Pro, and maybe even X3 Lite?)

Carlos  4 months ago
It won't install in my s21 ultra

Carlos  4 months ago
Or a OnePlus 8

J.H. Zwart  4 months ago
Perhaps more Oppo phones are supported, like the Find X3 Lite?
Also sent to the channel

J.H. Zwart  20 days ago
This modified APK for Nebula Service installs just fine (thanks to Now the 2D apps show up on every phone with Nebula Universal, but when opened all you get is empty black windows..... What could be missing? Maybe some OBB files?
15 kB APK15 kB — Click to download

Siddarth Kengadaran  17 days ago
Did you find a solution for the 2D apps showing up in empty black windows ?

J.H. Zwart  16 days ago
No, but I hope someone else does...

Jose Canovas  1 day ago
How can you make changes to the nebula application? I would be interested in being able to give access to the rtc web simply by supporting getUserMedia.
1 Like

Thank you very much for the paste and the link guys. Quite informative.
I’m giving it a shot this weekend with both the 2in1 2.01 version and then 1.04 service and 1.07 app(after twrp clean restore).

I’m also looking for a prop fingerprint for Magisk from one of the supported devices to try and install the carrier version from G Play and see how that pans out. Worth a shot :slight_smile:
Take care!

[EDIT] P.S. I’ve been out of the android space since version 8 and it looks like I have a bit of catching up to do. Honest to god I forgot about signing APK’s.


@wilcoboode Do you, by any chance have a valid invite link to slack? None of the links I have so far let me join the workspace. Might be something wrong with me though.

As a side note: there are some unity packages for webview and VNC on github that you can have a go at if it rocks your boat.

Any luck on 2D apps for universal app?

Yes… sort of… Old news really.
It’s working after installing the resigned xperia Nebula service but the capture/render is not working (aka - black rectangles instead of the app window).
I’m flashing a modified Lineage OS on my 9Pro on the 16th or so(when I get home) with Nebula service as system app and after I’ll try as a /priv-app. I’ll try both since I had no confirmation from nreal where exactly it’s installed on the carrier devices and I have no dumps to check what is where and how.

1 Like

Got it. I found the nebula service apk and see that the apps are empty. Any luck on rtrc webview?

Tbh a lot of problems would be gone if I manage to disable verified boot and flash my edited /system.
It doesn’t work on mine but it is possible that on some devices Magisk with the systemize plugin will do the trick of making Nebula service and app system apps.
For some reason magisk with systemize do not work on my phone. That is why it’s taking a lot longer.
I tried building LIneage OS with the apps baked in but it went wrong and I’m trying to find out why.
It will be a long painful one this :slight_smile: good fun ahead.

Just a quick update. Found what the problem is with the video capture/render not working properly for 2d apps.

It’s actually 2 problems:

1 - to get the app to install android:sharedUserId=“android.uid.system” is removed. This is actually required for the app to get the required priviledges for the video capture and interaction with the 2D app

2 - if android:sharedUserId=“android.uid.system” is left in the app needs to be signed with the same keys as the ROM you’re running(this is done by the ROM builder - aka Mobile providers in our case).#

Conclusion: The modified APK, even if it installs, will never work even if it’s systemized - already tried and disabled secure boot and flashed a modified /system with proper rights and all. It’s not having it.

The only (most likely)solutions we have available:

1 - build a custom ROM like LIneage OS for you device, sign the ROM and the(unmodified) APK with the generic keys

2- Convince (in my case) OnePlus to bake the nReal service and app in their Oxygen OS build (not going to happen without solid support from nReal)

If someone find any different please do correct me (I hope you do). In the meantime - I’m going to learn how to build Lineage OS by the looks of it.