Nebula not working as expected

Hi, just got glasses today. When I plug them in, I get the single monitor. If I launch Nebula, it asks me what setup I want, and launches. It flashes the screen, adjusting the display, but I get nothing on the glasses, and a black screen on the MacBook monitor.

Anything else I can try?


Hi, could you please tell me the model of your Macbook, and its system version? Thanks in advance.

MacBook Pro M1 Max, Max OS 12.6

Thanks for this info, the Mac model and OS should work well with our glass. Could you please confirm if all the permissions are allowed, including screen recording? If possible, please send me several pics or video which can show your steps, which is helpful for us to do troubleshooting.

Hi, I will try again tomorrow. I am certain that Screen Recording has permission, what are the others it requires?

Nope, that is the only permission it requires. Also, please disconnect other physical monitors before opening Mac Nebula.

Continuing the discussion from Nebula not working as expected:

Hello nreal dev, I tried opening the link once downloaded but it asks me to open application through the App Store, then on the App Store it says the app is not in my region. How do I get around this?
Thank you!

Hi! - I am having this same problem on 2020 MacBook Pro with M1 running macOS Ventura 13.1 - My glasses worked for 2 days when I first received them, and then this exact same situation happened. I’ve tried the following:

  1. Restarting Mac with the device unplugged
  2. Updating firmware
  3. Deleting Nebula and reinstalling

Extra details:

  1. This was starting to happen after the first day and I noticed it was happening when I would take the glasses off after using them, setting them down, and then coming back later to use them after they were sitting on the table still connected to the laptop.
  2. The Nebula icon is no longer in the upper right icon bar.
  3. Sometimes I’m getting the spinning wheel when hovering over the Nebula window as if it’s trying to connect to the glasses, and then the app crashes.

Please help!