Nebula on Samsung S10

According to the nreal website the Samsung Galaxy S10 is a supported phone (in Germany,
I can install Nebula 2.3.1 through the Playstore and open it. When I connect my glasses, they are first detected by Android as a second screen and I can see the phonescreen mirrored in the glasses. When I then start the MR Space in Nebula, the glasses don’t show anything. On the phone I can see the “touchpad” and the nreal home button.
Did anyone have the same issues (with an S10 or another phone) and knows how to solve it?

The glasses themselves are ok, I have an Oppo Find X3 pro, where they work as expected.


And just out of curiosity, why is the S10 supported in Germany, but not in Japan & S.Korea?

Hi Developer, could you please confirm if the model of your S10 is SM-G973F? If issue still, please upgrade Nebula to the latest.

1 Like

I’m having the same problem with my Galaxy S21 (SM-G991N). I already have the latest version of Nebula. Please let me know how to solve it.


Hi, also the MR space is enabled, the touchpad can be seen, but no image in glass? If so, please check if your Dex mode is disabled. Then try to re-plug the glass several times to see if the issue keeps the same.

Thanks for your reply.
It was solved by changing the processing speed to maximum in more battery settings.

1 Like

Hey I’m having the same issue. I’m able to use dex to mirror cast the screen. The audio works on the nreal airs but I can’t get the nebula app to work. I’m currently in sweden and downloaded the 3.2.3 newest version for non Google play atm. You said your problem was fixed by the battery settings… did you also have to disable dex? Or

Hi, before you do the battery setting, please diable the Dex mode first.

Thank you that worked. Is there a time you suggest “high proformance battery mode”