Nreal air mirror chrome os not working mirror

Spin 513 chrome os everything updated. Snapdragon 7c CPU. USB-C alt dp on 2 USB ports. Connected to nreal Air nothing happens. 1 second pop up with volume appears in chrome os. Glasses don’t power on despite clicking power button.

Is this a Chrome os arm CPU problem? I’ve heard other with Intel Chromebooks where the glasses works fine over USBC alt dp mirror mode

It actually recognizes nreal as an screen but no picture is displayed… makes no sense

Hi, please try to connect a physical monitor to your PC and check if there is any image. Also, please confirm the USB-C port on this PC can provide a 5V1A power supply.

I’ve tried with a USB monitor and it works with the Chromebook snapdragon via USB alt dp.
I’ve tried with my windows laptop and the nreal Air via UsbC alt dp and it works.

So something is going wrong with Chromebook USB alt dp with the snapdragon. Nreal is recognized as a screen with a resolution if 6xx*8xx resolution but no picture.

OK, thanks for this info. We never test the Chromebook before, so I will give feedback internally.

How fast do you think you can resolve this?

The glasses work with Chromebook with non arm CPUs (Intel etc.) (Mediatek and snapdragon) looks like it does not work.

I’m not sure about the time, it is determined by the source of R&D. Sorry about it.

But do you expect it to be solveable? I’m thinking about returning my Chromebook because of this…

I’m also not sure about that.

Did you speak about it with your team?

People have been requesting support for windows and linux with no progress. I doubt chromeos is even on their roadmap.

1 Like

I am also facing the same issue. Tested on 3 device:

Lenovo Flex 5 (Intel) working
HP X2 11 and Chromebook Duet 5 (ARM) not working

was wondering if anyone managed to make it work somehow

Just an update. I managed to make it work using HDMI dongle rather than USB-C. Connected the USB to HDMI dongle to NReal adapter and works. I doubt that the power is the issue cause it can pretty much detect the glasses when connected directly. It could probably the resolution or something which may not be compatible to the 2 devices. I hope NReal can help update the firmware for it.