Nreal air no display at all S21 ultra 5g

Hi ive just recieved my nreal airs and very frustrated that i cant get it to work with my s21 ultra 5g. My model is SM-998B Exynos and im from Australia so i was initially worried that it wouldnt work at all. So the big problem is that it works fine on my dads s21 ultra 5g, identical phone, same model as well, AR space working fully even in my region.
So why doesnt it work on my phone. Not only does AR space not show up, i get no image at all.
When i first plugged the airs into my 21 ultra I dex showed up, and it did display dex and mirroring, after a few seconds it glitched and the whole image was broken with artifacts, then it crashed and no image has shown up since. Not for dex or for mirroring.
Ive tried disabling dex, restarting my phone, downloading both latest 3.2.1 version of nebula and the 1gb apkcombo version.
Same result, no image at all not even for mirroring on my s21 ultra 5g which i know it works because my dad has the same phone with no problems, clear image with no artifacts too, very strange.
Now the clue is when i try to open ar space error 12 shows up, thats the only lead i have to try fix this.
Devs please fix this my phone is compatible and it clearly works with my dads identical phone what can i do?
Please help :pray:

Also Running android 13

Your dads phone has Android 13 too ?

Pretty sure, i dont think it would make a difference, but is anyone else on android 13 and experiencing issues aswell? Would have to ask tommorow to confirm if same android

Yes , I have fold 3 after updating to Android 13 my nreal light glasses are not connecting only mirroring works.

Could be the android version, will confirm tommorow, do you experience crashing and artifacts also? Mirroring doesnt work at all for me aswell

Not all phones with Android 13 are having the issue. Go to connections —-> more connections ——> HDMI. Select screen mirroring.

Also is your Air connecting to nebula ? Does it show maroon AR Space and Air casting buttons? Or just “Plug in your glasses to enter Nebula “ message?

Yea i always turn dex off and hdmi mode mirror. After trying a few fixes like reverting to nebula 3.1.1 it seems to work and launch ar space but everything crashes and artifacts after 2 seconds, it also shows device connected/disconnected repeatedly. Might be an android problem since ive cleaned my ports with alcohol, charging is never a problem.

Make sure the cables is plugged in the right way angled part on cable goes to the glasses side and straight end into samsung phone