Nreal Air not fully working with Samsung Galaxy S20 FE 5G SM-G781B DS phone


I purchased an nreal air from EE here in the U.K. and a Samsung Galaxy S20 FE 5G SM-G781B DS phone, as it’s listed on the U.K. compatible device list: [Compatibility](https://nreal compatibility list)

Phone software version: G781BXXS4FVD9 / G781BOXM4FVC4 / G781BXXS4FVE1

Nebula app version: 2.3.4 (1710)

The air cast works ok (the floating desktop display) but the laser pointer does not. I have to use the black trackpad with mouse pointer on the floating display.

Even worse, when I select MR Space Nebula crashes and on the phone a pop up appears saying disconnected from external display.

Please help! It’s very frustrating as I just unboxed all this today.

Thinking you in advance.


It sounds like you have DeX running. For MR Space to work you will need to disable it by going to:

Settings → Advanced Features → Samsung DeX

And toggling this off whilst the glasses are plugged in. Let me know if that doesn’t help! :slight_smile:

Thank you!

Problem solved - much appreciated George_Hopefully.

1 Like

I have a s20 5g and the nreal worked before but now has completely stoped working now. This is what the message keeps on saying

Hi, could you please tell me what specific model number of your S20 5G is, like SM-G781B? Also, if you phone is working before, then please check if your wire connection is well.

Its SM-G981B/DS. And yes ive used it many times before. Ive even tried them on my wifes phone which is the s21 ultra and the same things is happening. The wire seems in perfection condition. Ive uninstall the nebula app that doesnt do the trick and my phone does recognise the glasses because when i try and plug them in its counting down from 10 saying trying to connect.


Im having the same issue. Up until yesterday, it was working fine. Now i get a compatibility warning poping up with i try to use the glasses.

Ive tried un installing and reinstalling the app, and restrating the phone. Ensuring dex is off. But no luck. The cable looks fine too.

The phone is a samsung galaxy s20FE5G
SM-G781B. This is on the compatibility list, so im really confused whats happened!

Any help would be amazing!

In my case it was problem with still enabled Dex in Settings-Connections-More connection settings, HDMI mode was Samsung DeX I’ve switched to “Screen mirroring”.