NReal Devkit Main Menu Not Comming Up


we are currently using 6 NReal Devkits, bought in different times, but all has the same main menu problem. The main menu of NReal does not appear all the time when the glasses cable is plugged in. It is very annoying. Sometimes I have to take off and plug the cable several times in order to see the main menu of NReal glasses. Even sometime menu never come up and I have to push stand a few times to see the menu. I waited more than a year, but no update released yet solving that issue??

Best regards


Hi, could you please try to use a small sticker to cover the center P-Sensor? And then check if it shows the main menu instantly once you connect the glass.

It is always covered for months, since it makes problem.

We have released a new version for Dev kit in Sep, did you update it? Also, could you please also try the glass on an Android phone to check if there is same issue on Nebula?

We use NRSDK version 1.9.0 in Unity.
We cannot use Nebula since NReal does not work with our mobile phones we tried. We tested with Samsung S20 (not 5G). Glasses stops working after a few seconds, and restarts again, and we could not solve what is happening? We see 3D nebula menu for just a second, and then gone.

Thanks for this info, honestly I meant the system version of the Dev Kit, instead of NRSDK. Could you please check the current version (the latest version should be SDM845-202207211133-1014)? Also, you mentioned that S20 cannot work with glass, can I know the version of Nebula? Also, if it is possible to record a piece of video to show the current issue on Dev Kit? Thanks in advance.

System version exactly the same (SDM845-202207211133-1014). Firmware is
I will try to record the issue. For Nebula, I tried “” and “Nebula_Universal_v2.02.00.2111081602_1080_api29_2in1_release.apk”, and both had the same issue. After nebula space button is clicked, the 3D scene of nebula just show up less than a second, sometimes you do not even see the 3D scene, and a sound comes from the glasses (a little tick) and image gone, glasses restarts after a few seconds, nebula menu on mobile phone display comes again later on. When I push nebula space button, it switch off again.

OK, thanks. If possible, please also try the following Nebula version.