Nreal Light Apps not working (most of them)


I start another post, for another issue, to not mix up the issues… First my data:

  • Nreal Light, Firmware Version:
  • Nebula 3.2.1 (2551)
  • Android 13
  • Samsung Galaxy 20FE 5G
  • Region: Germany
  • DEX is off and HDMI Output is set aways from DEX

The most Apps for Nreal Light from the App Store do not work. They are crashing with “Error code-12 … MRSpace mode is needed …”. But some Apps do work (like Animal Walk, FarePlay), but the most do not: like: Maze, PupPup, Photo Gun, QB Planets Nreal, …

I have tried everything: restarted my phone, triple checked DEX settings, uninstalled and installed everything, downgraded Nebula. But nothing helped.

Does somebody have an idea?

1 Like

Hi, please go to Settings–>Display–>Full-Screen apps, then enable or add Nebula to it. After that, re-open your Nebula and enter AR Space.

Hi, I already had tried that and it didn‘t help.

OK, I got it. The incompatibility of these apps and Android 13 should cause this issue. I will discuss it with R&D members.

I also think so. Thanks.

Hi I am also having some of those issues I have a Samsung galaxy s10 I got nebula to work by disabling dex and having high performance mode on, and most of the apps work when you click like the lab app, the cycling app, the web app, but some do nothing you can hols down the button to move them around like photo gun but you can’t click it. Same with the weather widget and the calendar one. Kinda disappointing I’m not sure what to do.

Hi, the weather and calendar widgets cannot be clicked but you can move them. And for Photo Gun app, please confirm if the app is installed well, and what kind of specific phenomenon after you clicked the app.

Okay so the weather and calendar are my Gmail? The photo gun doesn’t do anything when clicked as if you clicked an empty space. You can hold+click and move it but not delete. If it helped I’m in EU so I have to use the non gp install

Hi, the data of the calendar and weather are from the Android system of your phone. The photo gun widget on the home screen is just a logo, you have to download the corresponding app from GP.

Thank you so much, I’ve downloaded the app it works now. I want to say how much the into3d app has improved my commute as well. I’m watching movies like I’m at the theater the 3d function works so well even with the light shade down!

No one in sweden where I am even knows about this tech…someone asked me if I worked in tech lol. (I’m a landscaper) I spread the word when I can! I hope you guys are the company everyone follows the product is great. You’re committed to us I appreciate the response.

1 Like

I’m sorry to double message, but I am in Europe (but use a us nreal air and macbook pro m1) and using a MacBook I have the newest version on a m1 and the beta app no longer works…can you direct me to the correct forum to check for updates on this ? I will eagerly wait and bookmark. I’m having trouble finding where to look I know you’re aware of the issue. … if it helps I can screen mirror my MacBook monitor but I can’t adjust the size or use the nebula app

Hi, could you please more details about the issue? Like if the Nebula app can be launched well and you can see the size adjustment window?

The nebula app launches and its mirroring my laptop monitor but nothing on the nebula app is clickable so I can’t actually get into the nebula or casting option. It’s just like the app opens and you have to manually X to close it and then it’s just your monitor mirrored but I can’t change the size or do anything multiple monitors like I can inside the nebula app. Part of why I got this was for the laptop capability I have the m1 MacBook pro . So I checked ahead. I get this is a beta so I’m here for the ride. I can take a picture of how it looks from my phone later today if you want to see what I’m seeing.

I have a Samsung ZFold 3 5G and all of the apps close as well. Is there anyone that gets the Light and Samusung ZFold 3 5G to work?

Could you please check if the Samsung dex mode is disabled before using the Nebula app?

Did you resolve this problem ? I have the same issue. Thanks

So you can enter the AR Space but cannot click any apps? Could you please tell me what specific apps cannot be clicked? And please confirm your current Android version, phone model, and Nebula version. Thanks in advance.

Im android 13 zfold3 xreal air.apps working, maze,animal walk,shoot em up,into 3d,everything else fault code 12

Thanks for the further info. Please go to Settings–>Display–>Full-screen apps, allow the Nebula app in the Full-screen apps. Also, please try to use Nebula with your phone folded, then check if the apps can be opened.