NReal Light Issues with rgb camera

The first time I try to take an screenshot with my NReal glasses I get kicked out of MR Space. Is there a known fix for this issue? When can we expect this issue to be resolved? I am building an app that uses the RGB camera and I am having a similar issue with it kicking me out of MR Space.

Steps to reproduce:

  1. If your glasses are connected to your phone, disconnect them.
  2. Reconnect your glasses to your phone.
  3. Enter “MR Space”
  4. Take a screenshot.
  5. You will be kicked out of “MR Space” and returned to the nebula app.
  6. Re-enter “MR Space”
  7. A screen shot will be taken automatically.
  8. Taking more screenshots will not reproduce the behavior until the glasses have been disconnected from your phone and reconnected.

I’ve tried this with and without developer mode enabled and I have verified each time that low power mode is turned off. With low power mode turned on I get a notification that the camera is unavailable while low power mode is on so this seems to be a different issue. I have observed this issue with both NRSDK 1.9.1 and NRSDK 1.9.3 (which is currently a preview version)

Hi developer. Could you please tell me if you disabled ‘Multithreaded Rendering’ before building your apk?


To answer your question, no, I did not disable multithreaded rendering, however I did just do a quick test with it disabled and I get the same behavior. I also don’t think that any of my app code/settings is the issue here since I am getting this exact behavior simply by using the system built in screenshot feature.


OK, then could you please help to create a full log by logcat? So we analyze it and try to locate the issue. Thanks in advance.

It seems I can’t attach text documents to my comments so here is a google drive link to the file:

This log starts just before I plugged in my nreal glasses to my phone, and ends just after I was kicked out of MR Space. So the relevant parts are likely closer to the end of the log.

Hello, have you ever tried to build the sample scene “RGBCamera-Capture” and reproduced this issue?
I tried to reproduce the problem with the steps you listed, but I failed, the function worked.

Yes I had reproduced this behavior on that demo as well. To help troubleshoot I’ve tested this again and captured a log. Here are the steps I took for this:

  1. Created a new unity project with Unity 2020.3.29f1
  2. Imported NRSDK 1.9.1
  3. Opened the RGBCamera-Capture scene
  4. Followed instructions to configure NRSDK as outlined HERE
  5. Built the project and installed on mobile phone
  6. Plugged in nreal light glasses to mobile phone
  7. Opened the RGBCamera-Capture app
  8. Attempt to take a picture by pressing the touchpad
  9. At this point I am kicked out of MR Space

HERE is a link to the log I captured while running steps 6-9.

I think my team is receiving a few more nreal light devices in the next day or so. I will try to reproduce this behavior on those devices as well when available.

Can you send me the apk? I want to test it on the dev kit and see what might cause the problem.

Hi, we’ve checked your log and found out that the RGB camera was initialized successfully. Please try to open the permission to take the screenshots.

Hello, I’ve finally gotten a hold of another pair of NReal Light’s and unfortunately I am having the same issue. So it seems that maybe this is a device compatibility issue. I am using the OnePlus 8T 5G (model number KB2005). This specific device model isn’t listed on any of the compatibility lists that I have found but a similar model (KB2003) is listed, I believe this is the OnePlus 8T (non-5G model). The list specifies that hand tracking is available but says nothing about the RGB camera. This leads me to two questions:

  1. Are you able to reproduce my steps on this device model (KB2005/KB2003)?
  2. Could I get some sort of timeline for when “official” camera support might be added to this device (if ever)?
  3. What would you recommend as the “most compatible” device to purchase in the US? Meaning it supports all the currently available features and is the most tested of those devices.

I really appreciate all the help I’ve been provided thus far. Thanks a lot!

This isue is still ongoing. I encountered the same issue, with the same device, model number ending in 003, before even finding the thread. Im in a similiar situation where im building an app dependent on the RGB cam. I suspect its a problem with the nebula app, since as mentioned above the standard screenshot function always crasher nebula on the first attempt. Afterwards its seems to work fine, and my app is able to take many screenshots. Same thing happens with the RGBCamera, RGBCameraCapture sample scenes provided with Unity.

Is there a confirmed device which has a working version of a screenshot or camera function? Maybe origianl poster you found a workaroud?

I noticed that you said the issue always occurred on the first attempt. Could you please confirm the phone model and Android version for me?

Same issue here.
My phone is moto G100 with Android12 (firmware build S1RTS32.41-20-16-1-9)
When opening camera, it crashes on the first attempt. When trying again, it opens normally.