Nreal's Hand Tracking Demo testing

Hi all, I’m using 1.6.0 NRSDK and testing Nreal’s ‘HandTracking’ prefab demo on the DevKit box.
We’re using Unity v2020.3.0f1.21. Everything works well whilst running inside the Unity Editor but at runtime (on the AR glasses) nothing is working correctly, i.e. all I can see is the demo menu, cube and 3 x static ‘laser beam’ lines and the controller does not work, so you cannot select any of the demo options, eg ‘Start HandTracking’. Is anyone else having the same issues? We’ve got the latest firmware too and have also followed Nreal’s tutorial exactly, here: Hand Tracking — NRSDK 1.6.0 documentation


Do you see your own hands when you try handtracking on the glasses or is it just not supported at all? I resignedly had the same problem but after I reinstalled the computing unit and updated the android launcher application to the latest software it worked. I found the solution on Slack. Maybe it helps :slight_smile:

Hello Tiyani and no, we cannot see any hands being displayed whilst running on the glasses and the hand controller doesn’t work either. I’ve done a factory reset on the computing unit, re-installed everything and also updated to NRSDKForUnityAndroid_1.7.0. All firmware is up to date too but still no success. It appears that the Hand Tracking feature is not being initialised properly when the demo runs. Would like to link up to LogCat (using Wifi) to see if we can debug this but not sure how to, is that something you know how to set up in Unity?

You could just install the unity logcat package from the assets store. After installing you can open up a terminal window and follow these steps: ADB over Wi-Fi - Famoco | Help Center.
Even if the firmware of the glasses is up-to-date and you’re using the right SDK it could still be a problem if you’re using an older android launcher. I would recommend updating it following the link I send earlier.

1 Like

I’ve got LogCat working and cannot see any crash messages after the Hands Tracking demo has launched, so guessing it must be an android issue.

Also, tried installing the android launcher you provided but always get the error below when doing so:

adb install -r ARLauncher_v0.2.2.apk
adb: failed to install ARLauncher_v0.2.2.apk: Failure [INSTALL_FAILED_VERSION_DOWNGRADE]

Hmh thats weird. I haven’t got that error. It seems that you have a different problem then. :frowning: hopefully someone else knows any other solutions.
I wish you the best of luck. :four_leaf_clover:

Is the HandTracking scene set up correctly?

Try selecting “Tracking 6 DoF” under the NRCameraRig prefab. Under the NRInput prefab select “Hands” as NR Input (Script). Also make sure that there is a right and left hand assigned to the NRInput and that they are enabled.

I hope that helps. Let me know how it goes!

Hello Robi, yes, all of those things you’ve mentioned are present and correct in the Unity project but the Hand Tracking demo is still not working for us. I’m suspecting now that we may have a faulty computing unit / glasses?

What does your process of installing the SDK on the computing unit look like? Are you already using “scrcpy”?

You might want to try installing Yoshinaga’s MRTK hand tracking demo, to confirm operation outside of your app: