"Please reconnect the glasses and restart Nebula" error with Mac. Also can't direct wired connect to my Mac Mini (with or without beam). What's going on?

Latest firmware and DP on my Airs. Latest Nebula update.

Glasses work fine on my iPad, Beam wired or airplay. Also works if I use the adapter/HDMI when wired to iPad. Using the supplied USB-C cables only.

So the ONLY way I can get a screen from my Mac is if I AirPlay with Beam. Wired connections dont work (even though they do with my iPad). I’ve created a new user on my machine and still doesn’t work. I also tried it on my wife’s M2 MacBook Pro and it also does not work (same problems). Also removed and reinstalled the app multiple times.

I submitted a bug report in the Nebula app, but im not confident I’ll get a quick response.

Nebula used to work, and I was also able to direct connect with cable if I wanted.

Please - anyone have any ideas?

1 Like

Hi, if you connect the Beam with your Mac by wired connection, there is no need to open Nebula and use it. Also, the Nebula will not work with this kind of connection.

I’ve got exact same problem but I don’t have the beam as they haven’s started selling it Australia yet. i can only use on my iPad pro and exact same message shows on my Mcbook

Hi, if you encounter the same issue while using Nebula for Mac. Please do the following steps:

  1. Check if the recording permission is granted for the app;
  2. Keep the glass cable connected to the Mac directly, please do not use a third-party adaptor or hub;
  3. Make sure that the OS of your Mac is higher than OS12
  4. If your Mac comes with an Intel chipset, please check if the Nebula for Mac is the latest.
  5. Disconnect other physical monitors;

After the steps above, please reboot your Mac and open Nebula for Mac again. Then connect the glass.

I know this. I’ve used Nebula on my Mac for over a year. The latest updates broke it. I’m just saying that the only way I can mirror my Mac to my Airs now is with the beam AirPlay. But that only gives me one screen and too much latency to actually use.

I’ve done this more times than I can count. It doesn’t work on my M1 Mac mini after the latest nebula update and firmware update on my airs.

For Mac mini, it is different to general Macbook, please note that the you need to connect another physical monitor for Mac Nebula to render virtual screen before connecting glass and launch Mac Nebula.
And for the M2 Macbook you mentioned, please check if the following setting is enabled:

Disconnected monitors from MacBook. Clicked on single screen (keeping it simple) then clicked on ‘Start AR Desktop’ then get a get a totally black display showing my cursor, menu bar a dock.
getting very frustrated

Hi, could you please try the operation I mentioned above? Also, please tell me your MacOS version and Nebula version. Thanks in advance.

I am having the same problem. Mac mini M1. Ventura 14. Nebula for mac beta from your website 3 days ago.
Have seen 3 virtual screens for a few seconds once. Since then same issues as ronjr. Thanks

I just followed these exact steps on ventura on mini M1 and now all 3 ar desktops work. Thank you XREAL-dev

1 Like