Problem Connecting xReal Air on Mac with MacOS 13.4


I have new xReal Air glasses and would like to connect to MacBook Pro 16 with MacOS 13.4

Here is what I tried to get it installed:

  1. Firmware update using Chrome: XREAL Air - Firmware update
  • downloads air_07.1.02.201_20230228.bin
  • connect
  • select firmware
  • MCU update → success, version
  • DP firmware update → success, vesions 1110

Now, I start Nebula:

  • first and it says “updating glasses”, runs to 100%
  • Then offers screen to select number of virtual screens
  • Then I click on “Start AR Desktop”
  • Then it runs for a while, and then I get “Please Reconnect the Glasses and Restart Nebula”
  • When I do that, I can re-start with "select number of virual screens, again end with “Reconnect and Restart Nebula”

Hi, seems I was using a usb c cable which was not good enough.
I have now connected glasses with usb c cable shipped with the glasses, now it works!

1 Like

Glad to hear that the issue was solved. We recommend using the default cable in the package.