[Solved] NReal Light Unity HelloMR on Mac


I’ve just pulled down the latest Unity SDK (1.8.0) and am trying to export a HelloMR.apk on the Mac.

Using Unity 2020.3.25f1, on a T-Mobile OnePlus, I’m unable to see anything at all when trying to run it through Nebula MR Space mode. (no image). The standard App and Home buttons appear on the OnePlus, but nothings appears in headset.

Do I need to back down to Unity 2019 for some reason, or move to PC for exporting? My impression is this use case as described above should work fine. Other Android apps are recognized and can use Air Casting; trying to run the app as standalone outside Nebula will throw a mode mismatch. No errors are being thrown otherwise.

SOLVED. Rather than deleting the thread, figured I would comment here for anyone that runs into the same issue.

Even though OpenGLES3 was set up as the primary Graphic API, Vulcan was still listed and was somehow overriding preferences. Completely removing Vulcan from the API list seemed to solve it for me.