System update failed

Hi there

I am trying to update System Version SDM845-202104261834-761 to SDM845-202106292249-837 on devkit

update download worked slow but fine but I get
“Sorry, System updating failed.” also after restart

Any clues how to continue from there ?

Thx a lot

I connected the devkit via USB-C (the port in which the glasses are usually plugged in) to my Laptop via scrpy
A great way to display the devkit android system on a simulated screen on my laptop.

i can now re-download und update via settings.
before I tried to update the system through the glasses display > Settings

will report back.

1 Like

Hey Cyberhippie,

My OTA update using the glasses failed so spectacularly I was sure the device had auto-bricked itself. Fortunately it auto-repaired itself and eventually managed to upgrade to latest. All without resorting to using srccpy. I have the black devkit.

Good luck with the update!

For OTA upgrade, please check this document:Specification of OTA cannot be Upgraded - Google Docs

Thank you for the link @XREAL-dev. Perhaps that document could be expanded on to make it a general trouble shooting guide. It would also be nice if it was made more visible, like in a forum section description or the pinned thread that already exists. Speaking of pinned threads I would expect those to be sorted as a group above other threads. That seems to be the whole idea of pinned threads looking at other forums.

One thing that could be added to the document when talking about factory reset is that it will unpair the controller. I saw here that it may be possible to pair it with an odd combination of starting things in a specific order and connecting and pulling cords? A very straight forward way of pairing the two is to do it in Android settings using scrcpy.


1 Like

Oh another thing on the topic of possible system update failures @XREAL-dev

My device shows a message briefly on startup/wakeup that says something similar to “Nreal light update running. | Press xxx to yyy.”. Is that just from a process that checks for and notifies the user about available updates or is it an indication of my previous upgrade going slightly bad? I OTA upgraded immediately when I got the devkit so I can’t recall if this behaviour was present before upgrade.