Trouble finding RecordedVideo path


I have tried to screen record my app a couple of times now but I can’t find the folder its in and I can’t pull the video. The unity project is set up correctly and I use the start and stop button to record my experience. The phone is connected to the pc through wifi and scrcpy but when I try to run the adb command * adb shell ls -Ral /sdcard/RecordVideos* I get an error telling me ** sdcard/RecordVideos: No such file or directory** is found.

I’ve tried entering the adb bash to search my way through the phone myself but no directory or file is found! It seems the video isn’t even created and I don’t know what I’m doing wrong.

I’ve followed the guide on the docs and It says the video should be saved to the ** Application.persistentDataPath** path. When trying to reach that path through my file explorer (%userprofile%\AppData\Local\Packages<productname>\LocalState) I can’t find anything there either.

Am I not screen recording correctly or the is there issues with the software?
All help appreciated

Why are you using the persistentDataPath for Windows if the glasses work on your Android phone? The persistentDataPath on your Android device is completely different. For me it is under Android/data/[package name]/files and the demo recording project in the sdk let me record it to this place.

1 Like

Because I followed this guide right here here and partially, to be honest, I was very very desperate.
I found the correct videos path earlier today though so I solved the issue.

1 Like

I do not see there any Windows path. But good to hear it worked for you now. :slight_smile:

…but sad, that you didn’t post an update here to inform others.

It says


and a quick google search told me this was in the AppData/Local/Packages folder. I plugged in my phone via USB after I filmed so I figured it maybe ended up in a unity folder hidden there somewhere since its a Unity project. As i said, I was desperate :slightly_smiling_face:

Well, I haven’t had the time since I’m still on the clock and I need to work. I was going to after work but now you did for me. Thanks :wink:

1 Like

yes, but the conclusion doesn’t make sense for me, because unity runs on like every platform so every platform has its own persistentDataPath - even the first result shows this: Unity - Scripting API: Application.persistentDataPath where there are like all platform with their own path listed, so…

I am sorry, I do not want to insult you, it is really hard to develop for this glasses since nreal doesnt respond to anything lately. even hand tracking doesnt work for me although I bought on the German release the ONLY phone which supported the glasses. it is frustrating to have such a bad support from something potential BIG, but hey, there will be other companies with better and cheaper hardware and community support and we don’t have to rely on them anymore. hopefully.

1 Like

I understand it doesn’t make any sense for you, I doesn’t have to. I’m not trying to be rude but I don’t expect of you to understand how my thought process works after 3 days of being stuck on something as stupid as this. Because you’re not me, you’re you. I don’t feel like explaining it either since It does not really have anything to do with the answer you gave me. I tried everything I possibly could come up with and It didn’t work, that’s why I said I was desperate. I scoured every corner trying to figure where to look since I couldn’t find it anywhere on the phone through the ABD command line. I couldn’t, so I turned to good old google machine and It pointed me in the wrong direction hence my question on this forum. Which I almost regret now. Please, in the future, don’t comment anyone’s “conclusion” or how they got there. It’s irrelevant to the issue and you only make people feel stupid. Be a better DEV than that.

Besides, this isn’t my first thread. I always make sure to answer my own questions IF I find an answer before it is presented to me. I try to answer other peoples questions also when I have the free time because I know how frustrating this software can be. So I don’t appreciate you assuming I don’t give back to the community.

Anyways, good luck with the handtracking. I’m going to try out myself in the near future. If I make any progress I’ll make sure to hit you up.

I am so sorry, I didn’t mean to be rude, but I think I am a little upset about the community support here in the board, because I was the only one who answered you, seems that the rest of the devs couldn’t help you either, what makes me thinking, where is the problem, does no one want to help each other or do they just not know either? I thought I would be stating, that some problems are just easier than most of all think, and someone does not have to think too complicated, you know? and sorry for insulting about not telling us, it is just that every time I see an old post with someone telling he managed it, but not telling how, makes me angry and sad. but more than good that you would have done it, I appreciate! because it seems there are too few of us here, even wanting to help

I were regurlarly here, but know I finished my prototype and don’t need to look into here, but sometimes it hits me and makes me sad how this potential good product is not supporting its devs, you know? I bet you are the best programmer, it needs time to develop a sense for problem solving, and now you are one step further, didn’t want to insult your capabilities. and also I bet you are way better than me, I just started developing for it.


Late to the party here, but when I use Application.persistantdatapath, and connect my phone to my PC, I have to navigate to:

phone\Internal shared storage\Android\data\\files

obviously replacing “” with your own app package.


Don’t stress it. I was under a lot of pressure yesterday so I just felt attacked intellectually. I didn’t mean to come on to you so harshly. I appreciate message, I also apologize. I know what you mean regarding the community support, because I feel the same way.This whole software learning process is just “trial and error” at this point, for everybody. I just wish people would take more time out of their day to help each other out, especially if they have been in the same spot(confused and ignored by the board).

You’re completely entitled to your anger regarding folks who don’t answer their own posts with solutions (if they find one). I feel the same way, it’s the most decent thing to do. But I swear I was going to reply to the thread. I’ve even done it before and I will always do that!

I’m glad you managed to finish your prototype! It’s really admirable of you to still come here and help people out, in the little way you can at least. And I most definitely NOT the best developer :joy:. But thank you! I’ve been using the NRSDK for about 4 weeks but I’ve only worked with the NR light for about a week. It’s a tough learning process as you say, It takes a lot of time to get the hang of it. I don’t know if you use discord but if you ever run into a problem I’d be happy to take a look at it with you (4 eyes are always better than 2 as they say), feel free to add me @ #0530 Armin. Cheers man, thanks again for your response to this thread! Hopefully more people will read our discussion and It’ll get them thinking about the possibility to get more active in this forum.


Precisely! You can like that also. Though a lot of other issues some folks are experiencing is that the files are not there when looking through finder/file explorer or some kind of UI like scrcpy. The best way is actually to use the ADB command line to navigate to these spots and pull the whole folder out with adb pull sdcard/android/data/