Why does AR Space not work for XReal Air?

XReal AR Space does not work for the XReal Air glasses any reason why?

1 Like

Hi, could you please tell me what kind of error code you got while entering AR Space? Also, please confirm the phone model number and Nebula version for me. Thanks in advance

Nebula 3.4.0
It wasnt given me a code just a telling me mode switch complete but would not switch
Samsung S21.
Nreal Air does not work at all

Thanks for your info. Please make sure the version of your Nebula is V3.4.0 (4040). And please note that the 72Hz on the new version is not supported on S21, switch it to 60Hz before entering AR Space.

Im alos having a similar problemI’m unable to launch AR SPACE ON Nebula successfully with my phone. My phone is a Samsung Z fold 4, nebula app version 3.4.0(4040). Xreal firmware version tried toggling setting from 60 to 72Hz and still have the same experience. Error is failed to initialize Xreal glasses 3D mode.

Hi, could you please try to fold your phone and switch the Nebula back to 60Hz? And check if it is OK.

Yeah, the same output folded or not.

I also have an another problem using my iPhone 14 and 13 with the Xreal glasses. It just does nothing when I plug into the Xreal. It just doesn’t cast to the Glasses at all.

PS: I have all the required adapters and cables to connect to the IPHONE

Thanks for your further info, please try to connect your glass to PC or gaming console directly, and check if there is any image in the glass. Also, you can try to force update the firmware of your glass by the Nebula ‘Help & Support->Restore basic firmware’

Hi, the glass seems to suddenly now work with the iPhone as expected. The only challenge still remains with the AR space on my Fold 4. Nothing seems to get it work. It keeps giving the same error.

Please check if you don’t turn off the Dex mode. You can go to Setting->Connectings->More Connection settings->HDMI mode, and check if the mode is set to Samsung Dex.

Thanks. This solved the problem. I had to shutdown Dev mode as you described and I was able to connect.
Thanks again