XREAL Air Glasses not working on Mac Mini M1


I am trying to connect my new XREAL Air glasses to my Mac Mini M1 computer. I downloaded the Nebula app from the XREAL webpage. I open the app and I get one of two windows that pop up and when I open the app. 1. It says to connect my glasses even when they are connected or 2. it will begin to update the glasses, reach 100%, and never will go the next page… I have tried everything I can think of. I quickly tried to double click on the screen when it opens but it opens a blank white screen. What can I do to get my desktop to enable on the glasses?

Hi, please check the following setting and make sure ‘Display have separate Spaces’ is enabled.

The Display in Separate spaces was already enabled. I turned it off and back on again to try to something, it is still not working in the same way I previously mentioned.

Thanx for that try, My Mac Mini is a M1 2020 edition if that can help anyone that would have any idea as to what I can do to get these glasses and app working. FYI the glasses do show the desktop without any icons or folders on it when I don’t go through the app. I was, only one time, able to see my actual desktop and open an app, but in this regular mode, the picture is so out of focus it is useless to me.

Sorry about the current issue. There is one more thing that I want to confirm, do you connect another physical monitor while using the glass and Nebula for Mac? For mac mini, it requires one physical monitor connected first.