XREAL Beam - Advertised functions are virtually unusable

Hey there! I just bought a new “XREAM Air” + “XREAL Beam” and I’m very happy with the glasses themselves. The glasses alone work as expected. What almost doesn’t work is the “Beam”. I’m now at the end of all my attempts to get the system to work properly. I’m an IT person and have a lot of technical experience, so I can rule out any mistakes on my part…

Using the Beam as AirPlay hardly works at all. As soon as I select the Beam on the iPhone/iPad, the connection is lost again shortly afterwards. Often there is simply no picture or sound, and often both are simply out of sync. I tried everything, connecting multiple times, rebooting, factory reset, nothing works…

The cable connection to the iPhone or iPad also DOESN’T WORK at all. The picture works, but the sound is jerky. No matter which app (YouTube, PLEX, AppleTV, Disney+), everyone has this problem. It’s definitely not the buffer’s fault, even local videos from the media library have the problem. Even when I connect my AirPods to Bluetooth, this problem still persists.

The only thing that works fine for me is the Nintendo Switch. Strangely enough, the sound works perfectly. I haven’t tried the PS5 yet. However, the iPhone and iPad are much more important to me.

I’ve tried everything and can’t find a solution…

My devices:


Launcher Version 924
Systemversion Q9F83A51186417

Apple iPhone 15 Pro, iOS 17.1
Apple 12,9" iPad Pro, iOS 17.1
Apple iPad (10. Gen), iOS 17.1

Any ideas?

1 Like

Hi, matthmu. Sorry for the issues that you have. For the out-of-sync issue, could you please tell me if you connected BLE earphones to your phone or iPad? By the way, the system version you mentioned is not correct, please check it again for me.
The second audio issue is a known issue on iOS/iPadOS 17, we will fix it in the next version of the Beam (it is expected to be released this week).

Sounds goog to me. I’m hoping for an update ASAP so that the system can at least be used with a cable. Even though AirPlay seems to be the bigger problem for me. Is there an official Changelog somewhere? Or where are such errors reported and, if necessary, confirmed? I could also contribute to a few translation errors (German).

The problem with the headphones occurs when I connect them to the Beam, not to the iPhone itself.

I checked the system version of my Beam again, it is:

1 Like

Thanks for your details. The system version is not the correct version on the Beam at present, we messed it with the ‘serial number’. Please check the ‘Serial Number’ on your Beam.
And for the issue, we fixed the out-of-sync issue while connecting BLE headphones to the Beam. Could you please tell me if your headphone is Airpods?

Serial Number of my Beam:

The problem with out-of-sync is with AirPods and my Sony MX4 Headphones.

Whats about my other questions?

Another strange thing I don’t understand:

When I connect the glasses to my Macbook and start Nebula, a message appears to update the glasses. (Software update?) However, as soon as I connect the glasses to the beam again, such an update display appears again. And he does it every time on both devices…

By the way, Nebula doesn’t work at all for me. (M2 Macbook Pro, macOS Sonoma 14.1) The glasses are recognized, but nothing else happens. At some point the message appears asking me to reconnect the glasses.

We have put the release note on Reddit. https://www.reddit.com/r/Xreal/wiki/index/faq/beam/releasenotes/

And for your issue, we will test it again internally. Is there any streaming apps you used and felt the sync issue?

It’s the same with everything, no matter what app.

1 Like

The firmware on Mac Nebula and Beam are different at present, so it will jump between these two platforms. We will keep them in the same version in the future version.
And please update your Mac Nebula to the latest V0.6.0. After that, please make sure the glass is connected directly to your Mac without any other adaptor. One more thing, please confirm the following setting is enabled before launching Nebula.

1 Like

Fine, now Nebula works. Thanks! :slight_smile:

Hi, the out-of-sync issue only occurs on some apps, not all of the streaming apps. It depends on the streaming mechanism of the app. Like YouTube, there is no such issue or maybe very little latency on audio. But like Korean TV, the streaming method is different from YT, the sync issue occurs cuz the Beam cannot decode this kind of streaming very well.

So I would be happy if the cable connection to the iPhone worked perfectly without the sound being so “distorted” and “choppy”. It’s just hard to describe. It reminds me of an very old notebook that was too weak to play YouTube videos with sound properly. It sounded similar. The sound stutters as if the CPU was overloaded. Really very strange, especially since the beam doesn’t have to encode or decode anything. So this is known and will definitely be fixed in the next update, yes?

Just purchased Xreal Air 2 and Xreal Beam, connected, went through the updates, then when I try to switch modes I get “this feature is available only on Xreal Air and is not supported on current devices”

This is obviously a bug since the latest Beam software should properly recognize the Air 2 as well

Posted here since I don’t know how to create new topic

Hi, the latest system of Beam(system version 335, launcher version 950) is compatible with XREAL Air 2 and Air 2 Pro. Please confirm the current system version of your Beam for me. Also, could you please tell me how you switch the mode by Beam? Thanks in advance.