Can a dev provide link to S_SDM845-202207211133-1014 ota.apk please?

Been trying to install the newest DevKit update but for some reason it downloads at a glacier pace. Took 24 hours to get to 30% then it reset back to zero (and that was using Scrpy method. In the glasses OS, it just failed after 2%.). Is it possible to get a link to the latest apk file for this? I installed the ones in the Google Doc but they are out of date.

Thanks for any help.

Hi, developer. I noticed that you said you installed the current system version by yourself before? If so, then you know how to use QFIL tool?

Thanks for your response. Maybe miscommunication as I didn’t flash install the current version, I simply upgraded using the links in the Google Doc. As such, I haven’t used the QFIL tool before, but I have experience flashing firmware and such on devices in the past. If you are able to provide the data for me to flash with the QFIL tool, Im happy to try getting it flashed onto the Devkit.

OK, so you flashed the firmware for the dev kit before. Then I just need to provide new firmware to you. Could you please tell me the capacity of your dev kit, 64G?

Thank you, yes, its the 64gb DevKit model.

Great thanks a lot. Will report back on how it went.

Sorry please do not use the link I sent, I uploaded a wrong one. I will give you a new one.

OK, no problem, Ill wait for the new one.

Please check this new link:

Hi again. Thanks for the assistance so far. I downloaded in flat mode to the devkit prog_firehose_ddr.elf with rawprogram_unsparse0.xml with patch0.xml and ufs storage type successfully. However, now the devkit is stuck in EDL mode. Holding down volume up + power, volume down + power and both for 20 seconds does not exit EDL mode, and when I plug it into the PC while doing this to check, it disconnects from the PC after 15 seconds of holding the button but then immediately reconnects, still in EDL mode (I checked this by looking at Device Manager and seeing it is still seen as Qualcomm HS-USB QDLoader 9008 on the commport list. Any recommendations for how to exit EDL mode? Or if I patched the wrong version, can you let me know which rawprogram and patch.xml to use? Thanks.

Could you please send me a picture which can show the current page? Then we can tell you what can be done next. Thanks

Here is a Google Drive link to the QFIL log and a screenshot of the situation.

Currently when I press the power button nothing happens, but when I plug it into the PC it appears in the device manager (see picture) and looks like it is in EDL mode.

Hi, I found the issue according to the picture you sent. You only selected one patch XML file. Please select all XML files, if you only got one XML file, then it was because that you also needed to select all the files in previous step.

Excellent. That worked and it updated no problem. Thanks for the help, greatly appreciated.

1 Like

Glad to hear that the issue was solved. :smiling_face_with_three_hearts:

Hi, I’ve been looking at using the QFIL tool to manually flash an update as well (I have inconsistent and slow internet). I am familiar with QFIL on some previous headsets/devices. I am having trouble getting the devkit to show up as a COM port device.

I have installed the qualcomm usb driver per the QFIL instructions and restarted (windows 10). But when I hold volume up and connect the devkit box with a USB-C to USB-A cable (I recall that QFIL doesn’t like USB-C to USB-C from previous experience) it doesn’t show up as a COM port device for flashing.

Is there a driver I am missing for the dev kit to be able to flash it? Or do I need to uninstall the existing driver being used when it’s in recovery?

Here is how it looks connected in recovery mode

Here is it in normal boot

@XREAL-dev any insight ^?

Hi, Tom. About the current issue, please contact for further help. Thanks

Never had a reply from is there another resource for manually flashing/updating the nreal box/glass?

I’m sorry that there is no other way to update the system version of computing unit.