Nebula Update!

Hi Devs,

Nebula has been updated to version V 2.01.00 with many new features and an improved user experience. Please download or update the latest Nebula on GooglePlay and check it out at . Share your user experience on our forum in the 【Nebula】category and talk to other developers about the updated Nebula! We will check forum regularly and answer your questions.

Added Features Highlight:

  • Photos application meets the basic photo album experience of users, and makes use of the spatial advantages to enhance personalized photo album ability.

  • Theater mode enables users to experience an ultimate immersive movie theater mode through one click while opening multiple windows.

  • Disabled force quit upon receiving low battery notification.

  • Optimized the sensitivity and accuracy of laser control in Nebula.

Discover the【hidden features】and share to the forum!

Will a developer mode sideload apk be made available for this updated version of Nebula for users who are unable to download directly on Google Play due to existing telecom/carrier restrictions?


is this sufficient? Slack

Found it on APKCombo. It works fine.

1 Like

Hidden features. Is it the 72 Hz refresh rate?

Hello, thanks for this updated version. Seems to be incompatible with my LG Velvet 5G.

In devloper options the 72Hz option is available. Is there more hidden?

Sorry was my fault. Didn’t place the obb files in the right way.
Works also very fine with my LG Velvet.

Thanks a lot.

Anyone get this to work for MR on US phones? The update goes black after selecting MR feature.

It only works if you have the APK plus the additional obb file, both of which are available at APKCombo but the posted Slack file doesn’t include the obb file. Download Nebula APK for Android (Free)

After installing the apk, you need to place the obb file in your /Android/obb/ subfolder in a new subfolder called ai.nreal.nebula.universal and then it should work.


Thanks. That worked.

1 Like

Cannot seem to get it working on mine. s20, US, dev mod. Old Red glasses. So either I’m missing a step with obb or these glasses are too old? I keep getting a version exception when I try to launch Nebula.


If it is saying your glasses are too old and to switch to the consumer model, you can usually skip that message and continue on to Nebula by pressing Okay.

Ah never mind. Seems I did not know you had to click the message 10x to get into dev mode.

1 Like

what did you click to go into developer mode on your android? and do you know the folders to place the downloaded nebula apk?

You just need to install the Nebula.apk and it will automatically create the folders it needs.

What should I do to get the predicted pose? * Who can help solve this post?


I’ve installed Nebula universal on my samsung s20+ 5g (Exynos 990 chip set), it launches but quickly looses the connection to the glasses and I get a “disconnected from …” message, it drops in and out every few seconds. If I just use the glasses as mirrored screen I have no problems. This only happens when I launch nebula. Maybe I have misunderstood but I thought the latest Nebula was supposed to work with this phone. Does anyone have any experience of this?


1 Like

Activate the flight mode of the phone after that Wifi. That works for me.

1 Like

Haha I had tried a few things like switching of blue tooth but not that. It worked great. I was beginning to think I would need to buy another phone.

Thanks for the quick response.