NRSDK 1.10.2 Apps crash after 10 minutes of run-time

I’ve faced the following bug:

Development Environment:

  • Windows 11
  • Unity 2022.3.5 (also tested on Unity 2022.3.1)
  • Android Oreo 8.1 API Level 27 (also tested on API level 32)
  • NR SDK 1.10.2 (also tested on 1.10.0, 1.9.5, 1.9.1)
  • XReal light glasses
  • XReal Development Kit Andriod Computing Unit (also tested on a Samsung S22 Ultra with Nebula)

Bug: XReal application crashes after 10 minutes of having the app run
To Replicate: Get NRSDK 1.10.2 into a Unity Project, open the default HelloMR scene, build that scene into the dev kit computing unit, open the app while wearing the glasses, do nothing other than wearing the glasses for 10 minutes and app will start freezing then crash (returns to the apps menu), alternatively, you can also tape the proximity sensor and after 10 minutes it will also crash.

Extra Note: this also happens on an empty scene with the default NR camera rig prefab, default NR input prefab, and NR Kernel Session Config that has both Plane detection and Image Tracking disabled. (it also happens while enabled but the point is that its not even because of too many recognition calculations)

I tested the same Hello-MR demo on my dev kit, put on the glass, and run the app for half an hour, it worked without the crash issue. Please go to setting of the Dev kit and change the sleep time to ‘never’.

for anyone facing the same issue. it was solved by switching to NRSDK 2.1 > switching to to Unity 2019 > referencing the Android SDK to be from Android Studio > installing Android SDK Command line tools version 8 and then renaming that file to latest > everything should work now and app won’t crash after first 10 minuets

1 Like